Touchscreen without funktion

Hi,

my Dexarm reacts to no input from the touchscreen. With the PC it works without problems. I cant also update the firmware on the touchscreen. Any idea?

Please confirm your dexarm and touchscreen version.
In the previous version, we changed the baud rate of touch screen communication, which may cause communication failure.

The latest version is Rotrics DexArm Firmware V2.2.1&Touchscreen Firmware V1.1.1

The DexArm Firmware is V2.2.1. The Touchscreen is 1.0.8. But i cant update it. I put the files on the card and press update. Then the screen turns off and on but it is still V 1.0.8.

Hi Tsmetz
1.Touchscreen Firmware should be V1.1.1
2.Please make sure you are directly replacing the previous file in the SD card, the directory and file location remain unchanged.
3.The touch screen must be powered by DexArm, not PC USB.
4.If the problem is still not resolved, please leave a message

I formatted the sd card and put the files again on it. Then the update worked. Now everything works fine.

1 Like