Rotrics Studio V1.0.0 Beta Version Testing

Hi DexArm Owners,
@trust_level_0

It’s been over six months since our last software update, we want to share a piece of good news with you. The new version of Rotrics Studio V1.0.0 beta is here! Welcome to download and test it:D

The new features include:

1. Added Rotary Module control section in Basic panel.
image

2. Added Sliding Rail and Conveyor Belt control section in Basic panel.
image

3. Added custom button area for you to send custom G-code commands to DexArm.
image

4. Added E axis value in axes Area.
image

5. Added Rotary Module into Teach&Play function and changed the block position value into XYZ axis value. We also change the UI of the suction cup and soft gripper status.

6. Added Rotary Module control block and sliding rail control blocks in Scratch. We noticed there are some translation issues in Scratch blocks. Will fix it in the officially released version.

We are also working on some other great features before releasing the V1.0.0 version:

  1. Add a config button for you to turn ON/OFF the physical limits of drawing and laser canvas. So that you can use the sliding rail to draw or laser engraves on a bigger area.

  2. Improving the Drawing and Laser text input section.

  3. Improving the 3D model operation area.

  4. Display real-time 3D printing temperature in 3D printing section.

  5. Display the Error message on Rotrics Studio.

The new version is scheduled to be released at the end of April. Please stay tuned:D

Download the beta version here > https://www.dropbox.com/sh/rrldp2l48vef2eb/AAA2sBiNPtyBaXJc92l1-yiwa?dl=0

Looking forward to hearing feedback from you:D

2 Likes

Wow,
that’s what I call a new version !!!
Have you just downloaded times.
And must say from the first attempts, absolute top.
Werd that tomorrow after work times test more precisely!

Many thanks to the Rotrics team, absolutely super the implantation of the Rotary Module and the rest I’ll look at tomorrow !!!

1 Like

Amazing work and happy to see an update. If you could look into the high CPU usage (70-100% on idle) I think it would be a solid update. Hint to look into three.js and the requestAnimationFrame loop to only update when a scene is changed, or a way to turn off scene.matrixAutoUpdate when there is no update to draw. Haven’t tried it yet but a fix on this would make the app much more snappy. Keep up the good job.

1 Like

Hi Blanck, thanks for the feedback. We will look into the CPU usage issue and try to resolve it:D

I can second this. The reason I’m not using Rotrics Studio is that it feels like it’s going to melt my macbook.

Hi
I m tring the new version.

  1. 3d print: first try the arm stop working after 45minutes…,second try is running but I have a litte bit underfeeding with filament. I uses the normal print settings.
  2. the arm has a problem with z near the body.
  3. sometimes the arm changes z (jumping)

Not sure if its a version problem…

Hi,

Would you like to share more details of your testing environment? Which computer system are you in?

We haven’t met any problem when 3D print over 30 hours with Rotrics Studio. Could you see any report in the Terminal panel when it stops printing?

Not sure what’s happening with the Z jumping issue. Could you take a video of it? It will help to locate the issue.

Thanks,
Jeff Lee

It’s great to see there is finally a new version, and I think all of us understand there can be delays in a kickstarted product, but you guys really have to do better with communication instead of practical radio silence for MONTHS. And even if the software doesn’t work yet, that’s no excuse for the manual site giving instructions that don’t work either, and saying there will be an update in “late October”. it hasn’t been updated since August. The sliding rail was the whole reason I bought the arm, and I have still not been able to get it to work. and I get it, it’s a kickstarter, but you have to communicate, don’t just leave everyone hanging for 6 months with no update on what’s going on. And at least keep the pages up to date on what you’re current status is, and with a workaround that actually works. other users have posted workarounds, so I know you can figure them out too.

1 Like

Still completely unclear on how to actually use the sliding rail. I can see there is now an E axis under control, but there is no button to move it like with the other axis. Where is the config button to turn on and off physical limits? I can’t find it? (Mac version).

1 Like

I have to echo @travellingtechie’s comments here. You are doing an awful job connecting with the community. This product is not a plug&play and we could all use some starter guides that are clear and more useful. At the very least publish a complete GCode documentation that tells us what commands are available and we’ll figure the rest out. In this form, this is great hardware but software and community support sucks big time.

There is a accessories to control Sliding Rail and conveyor belt.

Click the initialization button to initialize and then use the left and right buttons to control its movement.

The final released version will be delayed to May 10 because we have some new bugs to fix.

Sincerely sorry about the bad communication before. We will checking the community post more frequently and keep update the online manual.

Please tag me @Jeff_Rotrics if you need any help. I will be here soon.

1 Like