Dexarm worked initially but just stopped responding

My Dexarm worked perfectly when I received it but after about two months of intermittent use (drawing with a pen and laser engraving) it just stopped responding. It no longer reacts to Rotrics Studio running on a 2020 PC or to the handheld controller. I have the Dexarm in my office and because I found the music that played while the Dexarm was drawing or engraving I deleted the music files from the micro SD card in the handheld controller. I am not certain of the timing but I believe that the Dexarm stopped functioning after that. I updated both the Studio software and the firmware to versions V0.1.10 and V2.2.2 respectively, and the touchscreen firmware to V1.1.1. Thank you for any help you wish to offer.

Hi

Can you share your device information, like this:


If you can successfully upgrade DexArm to V2.2.2, it means that there should be no problem with the device.


This is touchscreen firmware V1.1.2.
There will be no music playing during the drawing process.