DexArm stopped working after a failed firmware update

The DexArm arrived today, and when I checked the operation, it initially worked fine.

I tried to update the firmware according to the online manual, but the update failed halfway through in Rotrics Studio.
So I tried to update the firmware with Tera Term.
It worked fine up to the point of sending the downloaded firmware, but soon the connection was lost by itself.

After that, I can connect the PC and the device, but I can’t operate the device at all. Even using the touch screen, it does not work.

I have rebooted and reconnected the PC and DexArm, disconnected other USB devices, and done everything else I can think of, but to no avail.

Is there anything I can do?

Translated with (free version)


have a look if you see a blinking LED in port 1 at the back of DexArm. If you see this your DexArm is still in “Flashing Mode” and not in “Operational Mode”. Many people had this issue.

You can manually transfer the Firmware to Dexarm with an external tool named “TerraTerm” (freeware; you will find it in Google)

Please follow this introductions:

If you have questions, in Discord is a big community which will help :wink:
You could also ask here, but the community is in Discord much more responsible. :wink:

Many Regards,


I am having this same issue. I downloaded Tera Term and followed the instructions. In the final step Tera Term gave me an error that the process was aborted. The instructions said to try again. Now even Tera Term can not connect to my COM Port. I select the port and then I get a blank screen in Tera Term. It will not accept any commands. Nothing happens at all.

Any suggestions?


i can help you, please get in direct contact with me in Discord: