3D printing using touchpad does not work properly - help!

Hello fellow Dexarm users. I’ve been playing around with the Dexarm for a month or so (mainly 3D printing) and it’s been working great when I run it from my laptop and Rotrics Studio. I’d like to take the prints “offline” by using the touchpad… however, I have yet to successfully start a print using the touchpad :frowning:
Here is my issue:
I initiate the file from the SD card and the arm doesn’t move and just extrudes filament in the air.

My procedure has been the following:

  1. After bootup, I go to “General” and press HOME (Dexarm moves to the correct position).
  2. I got to Settings -> Leveling -> press 1 (level it) -> Save -> press 2 (level it) Save -> press 3 (level it) -> Save -> press 4 (level it) Save -> press LEVEL (this is where things might start going wrong?)
    When I press LEVEL, the arm slacks entirely and “falls” onto my working surface. The motors make a whining sound. The arm never comes back up on it’s own. I have to go back to “Basic” -> HOME. The arm moves to HOME position (which looks correct).
  3. Then I go to 3D -> Set Origin (this is another area where things might be going wrong). Firstly, my menu looks different from the online tutorials (I have both “Set Origin” and “Set Height”). So I bring the arm down to the working height and press “Set Height”. Then I press “HOME” and bring the arm down to the working height and press “Set Origin”. Then I press “HOME” one last time.
  4. I go to SD card and execute gcode for my 3D print (note, this same gcode runs flawlessly from rotrics studio on my laptop). The arm then proceeds to warm up my filament and then doesn’t move while filament leaks out from the nozzle. To ensure it wasn’t my gcode not working properly, I tried running one of the preloaded gcodes and they have the same outcome.

Does anyone know what is going on or have any ideas on how I can sort this out? I’d love to be able to run the arm offline.

Thanks in advance!

Hi StasV

For G-code generated by Rotrics Studio, the working start point is X0 Y300. So when 3D printing with the touchscreen, you need to set G92 Z0 E0 (Set WorkHeight).
For G-code generated by third-party software, like Cura, the working start point is X0 Y0. So when 3D printing with the touchscreen, you need to set G92 X0 Y0 Z0 E0 (Set WorkOrigin/ Set Origin).

Please refer to this link,SetWorkOrigin & SetWorkHeight Difference:

Many users have mentioned this trouble, the next version of rotrics studio may change Set WorkHeight back to Set WorkOrigin

I also figure out that for example the home button at Touchscreen in 3D-Printing menue will reset WorkHeigh and WorkOrigin. Only use the home funnction in “General” menu to keep those settings stored. Since i take care of that i had no more those problems.